diff CMakeLists.txt @ 5:2db42eaba3c8

WIP
author Daniel O'Connor <darius@dons.net.au>
date Sat, 15 Feb 2025 22:57:18 +1030
parents b10097c3383d
children 3acdebd7eec7
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Feb 04 14:20:07 2025 +1030
+++ b/CMakeLists.txt	Sat Feb 15 22:57:18 2025 +1030
@@ -16,15 +16,25 @@
 
 add_executable(${NAME}
     modulator.c
-)
+    q/q.c
+    )
+
+# Bring the pain
+set_source_files_properties(modulator.c PROPERTIES COMPILE_OPTIONS -Wall -Wextra -Werror)
+set_source_files_properties(q/q.c PROPERTIES COMPILE_OPTIONS -DQVERSION=0x902)
+# XXX: this didn't work - everything got the flags
+#target_compile_options(${NAME} PRIVATE -Wall -Wextra -Werror)
 
 pico_generate_pio_header(${NAME} ${CMAKE_CURRENT_LIST_DIR}/dac.pio)
 
 target_link_libraries(${NAME}
 		pico_stdlib
+		hardware_clocks
 		hardware_dma
+		hardware_interp
 		hardware_irq
 		hardware_pio
+		hardware_pwm
 )
 
 #bin2elf(${NAME} shaped-trap.dat)